Resolved
Certificate have been renewed. The warning message should disappear in the following minutes / hours.
Identified
Many of our SSL certificates have expired which can cause your browsers to declare the website unsafe to browse. It's in fact not the case but to certificates are being renewed to resolve the issue.