Resolved
Affected services have recovered and are operating normally. We have deployed a mitigation to reduce the risk of recurrence and will continue internal follow-up on the underlying infrastructure issue.
Monitoring
On June 2, 2026 between 01:34 and 01:38 BST, an infrastructure issue caused a subset of services to become temporarily unavailable. Affected services have recovered, and we are
monitoring while we continue investigating the underlying cause.